NZBGet

NAS326, NAS520, NAS540, NAS542
Kuki
Beiträge: 38
Registriert: Mo 6. Jan 2020, 14:50

Re: NZBGet

Beitrag von Kuki »

@shv
Es wird nur ein File mit dem Dateinamen "Heiz" entpackt.

Benutzeravatar
shv
Beiträge: 74
Registriert: Sa 10. Nov 2018, 17:36

Re: NZBGet

Beitrag von shv »

Der korrekte Dateiname lautet Heizölrückstoßabdämpfung.bin. Obwohl LANG=en_US.UTF-8 gesetzt ist, wird beim Entpacken nicht der richtige Dateiname verwendet, weder beim automatischen Entpacken durch NZBGet, noch beim manuellen Entpacken direkt mit unrar. Den Wrapper von https://forum.nzbget.net/viewtopic.php?f=3&t=2795 habe ich nicht ausprobiert, da LANG bereits richtig gesetzt ist.

Mijzelf
Beiträge: 119
Registriert: Mi 14. Nov 2018, 19:50

Re: NZBGet

Beitrag von Mijzelf »

My experience with special characters is small, but I am wondering how you see that it's wrong. I mean, what is unrar puts the right characters, and you look at them using firmware busybox ls, which possibily doesn't support utf8?

Kuki
Beiträge: 38
Registriert: Mo 6. Jan 2020, 14:50

Re: NZBGet

Beitrag von Kuki »

@Mijzef
No, directly in the console (e.g. via SSH) we can see, that the files, containing special characters in the packed file names, are not named correcty.
In the example case prepared by shv you can see:

Code: Alles auswählen

admin@NAS540:/i-data/184cfa1c/nfs/public/nzb-downloads/dst/Other/reftestnzb-German-Umlauts-ea6f31c1c39c$ ls
Heiz
but the unopacked file name should be:
Heizölrückstoßabdämpfung.bin

So the file names are cut at the point, when the first special character ist coming.

What's the reason (unrar, nzbget, ...) and how to check it ... here I have unfortunately too low Linux knowledge, sorry.

Benutzeravatar
shv
Beiträge: 74
Registriert: Sa 10. Nov 2018, 17:36

Re: NZBGet

Beitrag von shv »

Scheint an Busybox zu liegen. Wenn ich diese Datei in ein Verzeichnis kopiere, auf welches ich über Samba zugreifen kann, sehe ich den richtigen Dateinamen. In /opt/etc/profile habe ich folgende Zeilen:

Code: Alles auswählen

export LANG='en_US.UTF-8'
export LC_ALL='en_US.UTF-8'
@Kuki, kannst Du bitte mal Entware unrar installieren, die Zeilen in /opt/etc/profile überprüfen und dann nochmal entpacken? Ich nehme an, dass nur Heiz angezeigt wird, wenn LC_ALL=C gesetzt ist. Evtl. erhälst Du damit das gleiche Ergebnis auch mit unrar aus dem Random Tools Package.

Wenn Du Putty verwendest, kann ich Dir folgende Einstellungen empfehlen:

Code: Alles auswählen

Window -> Translation -> Enable VT100 line drawing even in UTF-8 Mode
Window -> Colors -> Indicate bolded text by changing: The color
Connection -> Data -> Terminal-type string: xterm-color

Dateianhänge
MetaRepo.MC.1.png
MetaRepo.MC.1.png (10.98 KiB) 660 mal betrachtet

Antworten