Zyxel Forum - Herzlich Willkommen!

Aktuelle Zeit: Sa 22. Feb 2020, 16:35

Alle Zeiten sind UTC + 1 Stunde




Ein neues Thema erstellen Auf das Thema antworten  [ 21 Beiträge ]  Gehe zu Seite 1, 2, 3  Nächste
Autor Nachricht
 Betreff des Beitrags: Installing entware ourdays on NAS540
BeitragVerfasst: So 12. Jan 2020, 13:12 
Offline

Registriert: Mo 6. Jan 2020, 14:50
Beiträge: 27
Hi,
what is the current approach to install entware-ng today on a NAS540?
Still the stick from 2016?
Or to the HDD via the Metarepository?
Or using entware description from here? https://github.com/Entware/Entware/wiki ... xel-NAS542


Nach oben
 Profil  
 
BeitragVerfasst: So 12. Jan 2020, 20:09 
Offline

Registriert: Mi 14. Nov 2018, 19:50
Beiträge: 78
All of them will work, and all of them will give you Entware. But the github way will give you armv7sf-k3.2, while the other 2 ways will give armv7sf-k2.6. The difference is that k3.2 is compiled for linux 3.2, while k2.6 is compiled for linux 2.6.31, which is theoretically slower, although I don't think you'll feel the difference.


Nach oben
 Profil  
 
BeitragVerfasst: Di 14. Jan 2020, 13:04 
Offline

Registriert: Mo 6. Jan 2020, 14:50
Beiträge: 27
OK, I installed it from the MetaRepository (so the simplest way) ... but can't test it yet, as I'm copying a bigger amount of data for two days now and can't do a fresh reboot for it.
I'll report in the next two days.


Nach oben
 Profil  
 
BeitragVerfasst: Mi 15. Jan 2020, 04:47 
Offline

Registriert: Mo 6. Jan 2020, 14:50
Beiträge: 27
Update:
Even if the entware-ng "app" is appearing in the UI and is activated there (in the app center) and the page http://nas540:5000/pkg/Entware-ng/pkgcgi.cgi can be opened, it seems not to be installed properly:
Code:
root@NAS540:~# opkg update
-sh: opkg: not found

Any hint what to check or what to try next?


Nach oben
 Profil  
 
BeitragVerfasst: Mi 15. Jan 2020, 17:27 
Offline

Registriert: Mo 6. Jan 2020, 14:50
Beiträge: 27
here's the log after a NAS reboot:
Code:
Opened logfile at Wed Jan 15 04:32:41 CET 2020
Flushing memory buffer
    Starting up
Flushing done
[04:32:41] Create symlink /opt -> /i-data/068a2322/.PKG/Entware-ng/opt
[04:32:41] /opt/etc/init.d/rc.unslung is not available, start installer
[04:32:41]     Info: Opkg package manager deployment...
[04:32:41]     wget: bad address 'pkg.entware.net'
[04:32:41]     chmod: /opt/bin/opkg: No such file or directory
[04:32:41]     wget: bad address 'pkg.entware.net'
[04:32:41]     wget: bad address 'pkg.entware.net'
[04:32:41]     wget: bad address 'pkg.entware.net'
[04:32:41]     wget: bad address 'pkg.entware.net'
[04:32:41]     chmod: ld-2.22.so: No such file or directory
[04:32:42]     Info: Basic packages installation...
[04:32:42]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[04:32:42]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[04:32:42]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[04:32:42]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[04:32:42]     sed: /opt/etc/opkg.conf: No such file or directory
[04:32:42]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[04:32:42]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[04:32:42]     wget: bad address 'pkg.entware.net'
[04:32:42]     Info: Congratulations!
[04:32:42]     Info: If there are no errors above then Entware-ng was successfully initialized.
[04:32:42]     Info: Found a Bug? Please report at https://github.com/Entware-ng/Entware-ng/issues
[04:32:42] Execute /opt/etc/init.d/rc.unslung start
[04:32:42]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/etc/init.d/rc.unslung: not found
[04:32:42] Done /opt/etc/init.d/rc.unslung start
Closed logfile at Wed Jan 15 04:32:42 CET 2020


Nach oben
 Profil  
 
BeitragVerfasst: Mi 15. Jan 2020, 19:28 
Offline

Registriert: Mi 14. Nov 2018, 19:50
Beiträge: 78
Zitat:
[04:32:41] wget: bad address 'pkg.entware.net'
That's the problem. For some reason the NAS can't find pkg.entware.net. Without that it can't install Entware-ng.

Can you ping that address from the NAS?


Nach oben
 Profil  
 
BeitragVerfasst: Mi 15. Jan 2020, 19:48 
Offline

Registriert: Mo 6. Jan 2020, 14:50
Beiträge: 27
Hi Mijzelf,
yes, it's pingable. But perhaps there was a connection problem during the reboot, so that the installation went wrong.
I cant's reboot right now, but I'll try it tomorrow and deliver an update.

Code:
root@NAS540:~# ping pkg.entware.net
PING pkg.entware.net (104.27.177.50): 56 data bytes
64 bytes from 104.27.177.50: seq=0 ttl=58 time=55.202 ms
64 bytes from 104.27.177.50: seq=1 ttl=58 time=51.365 ms
64 bytes from 104.27.177.50: seq=2 ttl=58 time=50.749 ms
...


Nach oben
 Profil  
 
BeitragVerfasst: Mi 15. Jan 2020, 20:08 
Offline

Registriert: Mi 14. Nov 2018, 19:50
Beiträge: 78
You can simply dis- and enable Entware-ng in the packages menu to trigger a new install attempt.


Nach oben
 Profil  
 
BeitragVerfasst: Mi 15. Jan 2020, 21:01 
Offline

Registriert: Mo 6. Jan 2020, 14:50
Beiträge: 27
Yes, now it's installed! A simple stop and start didn't work. I had to unistall the app and reinstall it again. The installation took quite long (several minutes) so I suppose there was something wrong, but now it's there. Thanks!

- edit -

But an opkg update is still not working.

-- edit --
Hmm, the installation went wrong again. Some files couldn't be downloaded.

Code:
Opened logfile at Wed Jan 15 20:41:12 CET 2020
Flushing memory buffer
    Starting up
Flushing done
[20:41:12] Create symlink /opt -> /i-data/068a2322/.PKG/Entware-ng/opt
[20:41:12] /opt/etc/init.d/rc.unslung is not available, start installer
[20:41:12]     Info: Opkg package manager deployment...
[20:41:12]     Connecting to pkg.entware.net (104.27.177.50:80)
[20:41:12]     
opkg                 100% |*******************************|   124k  0:00:00 ETA
[20:41:12]     Connecting to pkg.entware.net (104.27.177.50:80)
[20:41:12]     
opkg.conf            100% |*******************************|   142   0:00:00 ETA
[20:41:12]     Connecting to pkg.entware.net (104.27.177.50:80)
[20:41:13]     
libgcc_s.so.1        100% |*******************************| 49120   0:00:00 ETA
[20:41:13]     Connecting to pkg.entware.net (104.27.177.50:80)
[20:41:13]     
ld-2.22.so           100% |*******************************|   131k  0:00:00 ETA
[20:41:13]     Connecting to pkg.entware.net (104.27.177.50:80)
[20:41:14]     
libc-2.22.so          65% |********************           |   791k  0:00:00 ETA
libc-2.22.so         100% |*******************************|  1198k  0:00:00 ETA
[20:41:14]     Info: Basic packages installation...
[20:41:14]     Downloading http://pkg.entware.net/binaries/armv7/Packages.gz.
[20:41:14]     Updated list of available packages in /opt/var/opkg-lists/packages.
[20:41:15]     Installing libc (2.23-6) to root...
[20:41:15]     Downloading http://pkg.entware.net/binaries/armv7/libc_2.23-6_armv7soft.ipk.
[20:41:16]     Installing libgcc (6.3.0-6) to root...
[20:41:16]     Downloading http://pkg.entware.net/binaries/armv7/libgcc_6.3.0-6_armv7soft.ipk.
[20:41:17]     Configuring libgcc.
[20:41:17]     Configuring libc.
[20:41:18]     Installing libpthread (2.23-6) to root...
[20:41:18]     Downloading http://pkg.entware.net/binaries/armv7/libpthread_2.23-6_armv7soft.ipk.
[20:41:19]     Configuring libpthread.
[20:41:20]     Installing entware-opt (222108-6) to root...
[20:41:20]     Downloading http://pkg.entware.net/binaries/armv7/entware-opt_222108-6_armv7soft.ipk.
[20:41:20]     Installing libssp (6.3.0-6) to root...
[20:41:20]     Downloading http://pkg.entware.net/binaries/armv7/libssp_6.3.0-6_armv7soft.ipk.
[20:41:20]     Installing librt (2.23-6) to root...
[20:41:20]     Downloading http://pkg.entware.net/binaries/armv7/librt_2.23-6_armv7soft.ipk.
[20:41:25]     Installing libstdcpp (6.3.0-6) to root...
[20:41:25]     Downloading http://pkg.entware.net/binaries/armv7/libstdcpp_6.3.0-6_armv7soft.ipk.
[20:56:29]     wget: download timed out
[20:56:29]     Collected errors:
[20:56:29]     * opkg_download: Failed to download http://pkg.entware.net/binaries/armv7/ldconfig_2.23-6_armv7soft.ipk, wget returned 1.
[20:56:29]     * opkg_install_pkg: Failed to download ldconfig. Perhaps you need to run 'opkg update'?
[20:56:29]     * opkg_install_cmd: Cannot install package entware-opt.
[20:56:29]     Installing ldconfig (2.23-6) to root...
[20:56:29]     Downloading http://pkg.entware.net/binaries/armv7/ldconfig_2.23-6_armv7soft.ipk.
[20:56:29]     Configuring libstdcpp.
[20:56:29]     Configuring librt.
[20:56:29]     Configuring libssp.


Let's stop for today. I have to wait until my raid repair (I added additional HDDs) is finished and then I'll reboot and reinstall and we'll see.


Nach oben
 Profil  
 
BeitragVerfasst: Do 16. Jan 2020, 19:33 
Offline

Registriert: Mo 6. Jan 2020, 14:50
Beiträge: 27
I had still no success. Again not working.
Code:
Opened logfile at Thu Jan 16 18:45:37 CET 2020
Flushing memory buffer
    Starting up
Flushing done
[18:45:37] Create symlink /opt -> /i-data/068a2322/.PKG/Entware-ng/opt
[18:45:37] /opt/etc/init.d/rc.unslung is not available, start installer
[18:45:37]     Info: Opkg package manager deployment...
[18:45:37]     wget: bad address 'pkg.entware.net'
[18:45:37]     chmod: /opt/bin/opkg: No such file or directory
[18:45:38]     wget: bad address 'pkg.entware.net'
[18:45:38]     wget: bad address 'pkg.entware.net'
[18:45:38]     wget: bad address 'pkg.entware.net'
[18:45:38]     wget: bad address 'pkg.entware.net'
[18:45:38]     chmod: ld-2.22.so: No such file or directory
[18:45:38]     Info: Basic packages installation...
[18:45:38]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[18:45:38]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[18:45:38]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[18:45:38]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[18:45:38]     sed: /opt/etc/opkg.conf: No such file or directory
[18:45:38]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[18:45:38]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/bin/opkg: not found
[18:45:38]     wget: bad address 'pkg.entware.net'
[18:45:38]     Info: Congratulations!
[18:45:38]     Info: If there are no errors above then Entware-ng was successfully initialized.
[18:45:38]     Info: Found a Bug? Please report at https://github.com/Entware-ng/Entware-ng/issues
[18:45:38] Execute /opt/etc/init.d/rc.unslung start
[18:45:38]     /i-data/068a2322/.PKG/Entware-ng//etc/init.d/Entware-ng: line 596: /opt/etc/init.d/rc.unslung: not found
[18:45:38] Done /opt/etc/init.d/rc.unslung start
Closed logfile at Thu Jan 16 18:45:38 CET 2020



Question:
When I uninstall entware-ng and reboot, there is still a symlink /opt showing to the non existing folder under .../.PKG/Entware-ng/
Shall I perhaps delete this symlink (when the package is unsinstalled) and try an installation again?!


Nach oben
 Profil  
 
Beiträge der letzten Zeit anzeigen:  Sortiere nach  
Ein neues Thema erstellen Auf das Thema antworten  [ 21 Beiträge ]  Gehe zu Seite 1, 2, 3  Nächste

Alle Zeiten sind UTC + 1 Stunde


Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast


Du darfst keine neuen Themen in diesem Forum erstellen.
Du darfst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge in diesem Forum nicht ändern.
Du darfst deine Beiträge in diesem Forum nicht löschen.
Du darfst keine Dateianhänge in diesem Forum erstellen.

Suche nach:
Gehe zu:  
cron
Powered by phpBB® Forum Software © phpBB Group
Deutsche Übersetzung durch phpBB.de