Entware php7 fehler

NAS326, NAS520, NAS540, NAS542
Antworten
Robby
Beiträge: 6
Registriert: Mo 3. Dez 2018, 13:47

Entware php7 fehler

Beitrag von Robby »

Habe versuch php7 zu Installieren (owncloud 10.)
Laut entware habe ich php7
root@Robby-Nas:~# opkg list-installed
busybox - 1.27.2-2
bzip2 - 1.0.6-3
entware-opt - 227000-3
entware-release - 1.0-2
entware-upgrade - 1.0-1
gzip - 1.8-1
icu - 60.2-1
libatomic - 6.3.0-6
libbz2 - 1.0.6-3
libc - 2.23-6
libcurl - 7.57.0-1
libevent2 - 2.0.22-1
libfreetype - 2.8.1-2
libgcc - 6.3.0-6
libiconv-full - 1.11.1-3
libjpeg - 9a-1
libltdl - 2.4-2
libmariadb - 5.5.58-1
libmcrypt - 2.5.8-2
libncurses - 6.0-1c
libncursesw - 6.0-1c
libopenssl - 1.0.2n-1
libpcre - 8.41-2
libpng - 1.6.34-1
libpthread - 2.23-6
libreadline - 7.0-1
librt - 2.23-6
libsqlite3 - 3210000-1
libssp - 6.3.0-6
libstdcpp - 6.3.0-6
libxml2 - 2.9.7-1
lighttpd - 1.4.48-2
lighttpd-mod-access - 1.4.48-2
lighttpd-mod-compress - 1.4.48-2
lighttpd-mod-expire - 1.4.48-2
lighttpd-mod-fastcgi - 1.4.48-2
lighttpd-mod-setenv - 1.4.48-2
mariadb-client - 5.5.58-1
mariadb-server - 5.5.58-1
php7 - 7.1.12-3
php7-cgi - 7.1.12-3
php7-cli - 7.1.12-3
php7-fastcgi - 7.1.12-3
php7-mod-ctype - 7.1.12-3
php7-mod-curl - 7.1.12-3
php7-mod-dom - 7.1.12-3
php7-mod-fileinfo - 7.1.12-3
php7-mod-gd - 7.1.12-3
php7-mod-hash - 7.1.12-3
php7-mod-iconv - 7.1.12-3
php7-mod-intl - 7.1.12-3
php7-mod-json - 7.1.12-3
php7-mod-mbstring - 7.1.12-3
php7-mod-mcrypt - 7.1.12-3
php7-mod-openssl - 7.1.12-3
php7-mod-pcntl - 7.1.12-3
php7-mod-pdo - 7.1.12-3
php7-mod-pdo-mysql - 7.1.12-3
php7-mod-pdo-sqlite - 7.1.12-3
php7-mod-session - 7.1.12-3
php7-mod-simplexml - 7.1.12-3
php7-mod-sockets - 7.1.12-3
php7-mod-sqlite3 - 7.1.12-3
php7-mod-xml - 7.1.12-3
php7-mod-xmlreader - 7.1.12-3
php7-mod-xmlwriter - 7.1.12-3
php7-mod-zip - 7.1.12-3
profile-hook - 0.1
redis - 4.0.6-1
resolveip - 2
terminfo - 6.0-1c
transmission-daemon-openssl - 2.92+git-5
transmission-web - 2.94-4
zlib - 1.2.11-1
root@Robby-Nas:~#
Doch owncloud sagt ich hätte php5.
Wie installiere ich php7 richtig !????

Danke für jeden hinweist.

Mijzelf
Beiträge: 113
Registriert: Mi 14. Nov 2018, 19:50

Re: Entware php7 fehler

Beitrag von Mijzelf »

Entware-ng is designed to co-exist with the firmware with as less interaction as possible, to prevent the firmware from mal-functioning. This also means that php installed in Entware-ng is not even detected by the firmware (and by stock packages).

If you want to use php7 to run owncloud, you'll have to use one of Entware-ng's webservers.

Robby
Beiträge: 6
Registriert: Mo 3. Dez 2018, 13:47

Re: Entware php7 fehler

Beitrag von Robby »

Danke Mijzelf
Das ist eine klare Aussage...
Also bleib mir nix anderes als ein webserver zu installieren.
Habe es mit "OpenMediaVault" (SD-Karte) versucht,war ok aber für dauerbetrieb :-/
Welchen "Webserver"kannst du mir für den NAS542 V5.21 empfehlen ??
und wann wird Entware 3.x für uns verfügbar sein ?.


Thanks Mijzelf
That's a clear statement ...
So stay with me nothing else than a webserver to install.
Did it with "OpenMediaVault" (SD card) tried, was ok but for continuous operation: - /
Which "web server" can you recommend me for the NAS542 V5.21 ??
and when will Entware 3.x be available for us?

Mijzelf
Beiträge: 113
Registriert: Mi 14. Nov 2018, 19:50

Re: Entware php7 fehler

Beitrag von Mijzelf »

The 542 has enough 'oemph' to run any webserver. The Entware repo contains the 3 'big ones', Apache, nginx and lighttpd. They will all do their job. I would choose for nginx, for no other reason than that it's the most modern one.

About Entware 3.x, what exactly do you mean? The naming of the various Entware versions is a mess. First there was Entware, then there was Entware-ng. Together with Entware-ng there was Entware 3, which was basically the same as Entware-ng, but targeting the 3.x kernel. (while Entware-ng targeted 2.6.32).
Now both Entware-ng and Entware 3 are superseded by, drumrolls, Entware.
And AFAIK your Entware-ng is automatically upgraded to Entware at install. That happens on fw5 devices. (Fortunately not on fw5 devices, they are not compatible)

Antworten