NAS540: When backup [rsync] error starting client-server protocol

NAS326, NAS520, NAS540, NAS542
Antworten
Sprocki
Beiträge: 18
Registriert: So 3. Mai 2020, 09:57

NAS540: When backup [rsync] error starting client-server protocol

Beitrag von Sprocki »

I have a daily rsync job that mirrors all data from NAS1 to NAS2. This worked for years. For a few days, I see these messages in my log file:

Code: Alles auswählen

When backup [rsync] error starting client-server protocol
At first I thought it would work the next day again, so I waited for that. Same result. Then I started the job manually but it failed as well. I searched for more detailed information in the web interface, but there is only the response of the rsync job in the task planner and the same message in the maintenance protocol. Not helpful.
I logged in to SSH and did not find much either. There is no entry in the crontab at the scheduled time of the day which I expected. I searcheed for /var/log/messages but that file does not exist. Where do I need to look for? I did not find any log file for the rsync jobs or files for the raw configuration that is written when the job is created in the web UI.

As the web interface is lacking all edit and almost all view methods to inspect the job that worked for years, I disabled that one and set up a new one. It took twelf hours to copy files from NAS1 to NAS2 and finished with a 'successful' message. I checked the files: NAS2 had ca. 80% of data before setting up the new job, now it has about 85% of the data received from NAS1. There are files that exist with the same date stamp and protection bits in source and target but the file size differs a lot, e.g. 127GB on NAS1 but only 9GB on NAS2. This is definitely not what rsync can call 'successful'.

Where can I find log files on the rsync job that might tell me why the old job stopped working and the new one did synchronize only 90% of the data?

Mijzelf
Beiträge: 108
Registriert: Mi 14. Nov 2018, 19:50

Re: NAS540: When backup [rsync] error starting client-server protocol

Beitrag von Mijzelf »

When backup [rsync] error starting client-server protocol
Long shot. is port 873 occupied?

Code: Alles auswählen

netstat -lptn

Sprocki
Beiträge: 18
Registriert: So 3. Mai 2020, 09:57

Re: NAS540: When backup [rsync] error starting client-server protocol

Beitrag von Sprocki »

Yes, it looks like this:

Code: Alles auswählen

Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 127.0.0.1:514           0.0.0.0:*               LISTEN      1800/syslog-ng
tcp        0      0 0.0.0.0:548             0.0.0.0:*               LISTEN      2686/afpd
tcp        0      0 0.0.0.0:5000            0.0.0.0:*               LISTEN      2302/pkg_httpd
tcp        0      0 0.0.0.0:873             0.0.0.0:*               LISTEN      3169/zysync
[...]
tcp        0      0 :::873                  :::*                    LISTEN      3169/zysync
tcp        0      0 :::139                  :::*                    LISTEN      2597/smbd
tcp        0      0 :::22                   :::*                    LISTEN      1670/sshd
tcp        0      0 :::445                  :::*                    LISTEN      2597/smbd

Mijzelf
Beiträge: 108
Registriert: Mi 14. Nov 2018, 19:50

Re: NAS540: When backup [rsync] error starting client-server protocol

Beitrag von Mijzelf »

Right. Did you recently install the BackupPlaner package? It installs a daemon 'zysync', which is an adapted, but incompatible version of rsync, which occupies the rsync port. In that case you can uninstall the BackupPlaner, kill zysync before you start your script, or use another port.

Antworten